Runs Degradation

Incident Report for Pandium

Resolved

This incident has been resolved and we're monitoring to ensure performance.
Posted Nov 15, 2023 - 11:00 EST

Update

Activity reports are slow to load via the UI. There is no issue with runs or integrations.
Posted Nov 15, 2023 - 10:59 EST

Identified

Runs are currently processing slower than normal. We are currently addressing the issue and will update shortly.
Posted Nov 15, 2023 - 10:45 EST
This incident affected: North America (Admin Dashboard).