Some marketplaces degraded

Incident Report for Pandium

Resolved

This issue is resolved.
Posted May 24, 2023 - 09:29 EDT

Monitoring

A fix has been implemented and we are monitoring
Posted May 24, 2023 - 09:21 EDT

Investigating

We are currently investigating this issue. Runs are not affected.
Posted May 24, 2023 - 09:20 EDT
This incident affected: North America (Marketplaces).